Random USB issue during show

We’ve had 3.1 and an EX connected via usb. Random times during service, the usb connection alert shows up and quickly goes away, without touching anything. This is followed by every single button from highlight all the way through Rx are selected as well as a every fixture being highlighted. The show goes straight to the last cue in the list. It also digitally sets all faders to 100%. Unfortunately, I have my haze machine cue controlled on a fad and it just blows 100% & 100%. My only recourse is to run down to the stage to unplug it to shut it off. Without resetting the software, I have no control over anything. I can see the ex communicating as I have a visual of it on my external screen, but it has no affect on the cue trying to recover.

I’ve checked the vista logs for the time stamp where it occurred and I see nothing about a USB disconnect to the EX

I have had it happen both while using NDI as well as when not using NDI

This issue causes the congregation to panic because it also brings the house lights to 100% as they too are assigned to a fader.

I’m running an HP all-in-one, windows 11 home, celeron j4025 @2ghz. 4gb of Ram. I didn’t buy this machine, it came with our setup.
Vista 3 R4 build 1679.
Ex firmware 464M/0.1

@jack.moorhouse i just realized that I should have submitted a ticket. Any chance you could offer pearls of wisdom?

I realize most will suggest a Ram upgrade, which I am ok with. I just don’t want to spend the money if there is something else wrong too. Ive uploaded logs and screenshots

VistaLogs.zip (829.1 KB)

I’d actually like to add that I’ve encountered nearly the exact same phenomena on occasion in one of the spaces at my church. We’ve got a Vista EX as well, connected via USB to a Mac Mini running MacOS Catalina. I’ve (thankfully!) never had it happen during a service, but it has happened during rehearsals or occasionally while programming. Probably happened once every two months at most.

What appears to happen for us is that every button is pressed in every state possible and every fader is set to 100, exactly like what happened in the images above. However, I don’t think I’ve ever gotten the “USB device disconnected” dialog box when this has happened. It kinda just decides to happen out of the blue. Other than this, our USB connection to the EX is extremely stable.

I think to fix the issues I would usually just reboot vista and power cycle the console, but obviously that isn’t ideal. Again, thankfully this hasn’t happened for me during a service, otherwise I would have mentioned it sooner.


Please do submit an official support ticket if my below comment does not help…

(I dont think you have a RAM or PC issue).

Would you believe it, we have seen some similar reports that have been solved by changing the USB cable to a super shielded variant. For example:

Are you able to source the above cable locally and report back?

I have submitted an official ticket. Also, I just purchased it on amazon. It will arrive Wednesday. I will follow up if it happens again

Hello !
Unfortunately, I also regularly encounter a similar situation on PC. I bought EX to work at concerts and I’m afraid to take it to concerts because of unpredictable USB disconnection. Support traditionally wrote about replacing the USB cable, but I checked 6 different, perfectly shielded ones and it did not help - by the way, if we know about the problem with USB cables, why do dealers sell these consoles with the wrong cables !!!???

Finally, it was suggested that I return the console under warranty (mine is 2 months old), but I hope that in your case you will not need to replace it with a new EX

We’ve seen similar “disconnect” issues and the only way we were able to recover was by power cycling the EX console. That restored control. Hopefully we resolved the issue going forward by using a better cable and we moved it from a USB Hub to a direct connection between the EX and the Mac Mini. Haven’t had any issues since making that change. Good Luck.

@jack.moorhouse I replaced the USB cable with your suggestion. We also upgraded our RAM to 8gb and created a support ticket. The issue still occurs at the most inopportune times. I am going to purchase a powered USB hub and try that. The Ex is currently straight to the USB-SS port If that doesn’t work, this issue needs to be elevated and resolved. The church has spent a good amount of money on this software key and EX board. We literally have folks yell when the house lights go to full during a sermon and haze starts to flood the stage (as stated above, I use a fader to control my haze cuelist).

@VistaSupport Please advise what steps Chroma staff is going to, or are currently doing to resolve this problem.

@VistaSupport Since I have the same problems, I will also ask the same questions - unfortunately, if nothing improves, I will have to return the EX
I wonder why my old M1 or S3 can work without any problems - I only have bad experiences with the EX,

Hello !

@DGHofstee I have another question about your EX, do you have a version where, looking from the back, there is a lamp socket on the left, two DMX sockets, and on the right, power supply and USB? ( although on the right it already had a 4pin XLR power supply)

or the version with the DMX sockets, power supply and lamp (from the photo) on the right side?This is what I bought and have

Today I had the version from the first photo - same computer, same USB cable and no problems.

@VistaSupport Has anything changed in the hardware along with the change in the arrangement of the DMX outputs, power supply and lamps - maybe this is the key to the problems?

Yes, the top image (with no power switch) was in circulation for the first batch of consoles.
The first batch was actually recalled because of a third party issue with the vinyl wrap. At the same time we had an opportunity to replace and improve the CPU card. It’s actually much improved in the bottom photo.
Therefore if anyone is in possession of a console with no switch (top image) contact support and we can get this warranty replaced, even if the console is over 2 years old at this point.

I just had the older EX version for two days and it worked without any problems. My newer version on the same computer and the same USB cables restarts from time to time. I’m trying to find the reason for this happening with the EX I have