M1 not staying connected to Mac mini

We have a Mac mini (running High Sierra) and an M1 controller. We have been running V2.3 fine for a while now. I saved my show file and clean installed V3 build 525 on the Mac and imported the V2 show file and the M1 connected fine. However, if I shut down Vista or restart the computer, the connection to the M1 is lost and I can’t get it back. I have tried a different USB cable, reinstalling the sentinel driver, etc. I don’t know what else to do. We have had to re-install V2.3 back onto the computer and go back to that to be able to use Vista at all - but we really want to be able to use V3. We have the exact same setup in our sanctuary and had NO issues when we upgraded to V3 in there. Not sure how to fix this. Any ideas?

We’re having this same issue in one of our rooms. Running Mojave on a Mac mini with an M1 and V3R2
We’ve had some luck just unplugging and replugging repeatedly, and sometimes moving to a different port on the computer.
I forgot about the “rescan for USB devices” menu option and will try that next time and see if that does anything but I’d prefer not to have to smash that 6 times before I get my show open. Doesn’t inspire confidence for a speedy recovery in the event of a crash.
It’s worth noting that we have two separate user accounts and show files, don’t know if that plays into it in any way.

Has it worked in V3 at all? I had to use the New Show trick for two of my machines.

I’m still using v2.3 on an imac running el capitan with an M1 - I had problems with the newer OS as they cause the USB bus to go into a low power state when the screen goes off. Once the M1 is disconnected I found you had to remove the DMX cable, re plug the usb cable, rescan usb devices and then reinstall the dmx cable.

Not sure if I want to go V3 as I will have to upgrade the OS and can’t have the M1 going offline as volunteers have problems troubleshooting…