MV dead (not working) after 3 R3 firmware upgrade

Today we updated our macOS computer to Vista 3 R3, and when first running the updated software it started to perform a firmware upgrade to our MV console surface. When the progress bar for the upgrade was at about 20%, the Vista application crashed. Upon re-launching Vista, our MV surface was completely unresponsive. Clicking “Identify Console” shows “Not Connected.”

We have tried rebooting the computer, unplugging and reconnecting the MV, and quitting and re-launching Vista. We’ve tried these things many times and in different orders. Our MV surface is still completely unresponsive.

Any advice on how we can get our MV surface working again?

Hi Luc,

Submit a support request with a photo of the error message that you receive when launching Vista.

It sounds like your MV is stuck in firmware flash state. Submit a support request, we will able to find out more and talk you through it there.

Jack

UPDATE:

I’m working with this same surface. I downloaded Vista3 R3 on a PC running Windows 10, hooked up the MV to a PC, and it works perfectly. Did the same thing on a different Mac (Mojave, same as the original Mac the surface was connected to), and the MV is still non responsive.

Didn’t solve the issue, but the plot thickens…thoughts?

Same answer as above to be honest. Submit a support request with an export of your log files. We will have more clues to be able to advise then :slight_smile: