M1 button modifier issue

hi all,
after have connected an m1 to vista3 i noticed the red,green,yellow and blue modifiere buttons are not working, everything else yes but not these buttons.
I updated the firmware too but nothing changed.
p.s. i tried on v2.3 and they are correctly working.

Hello Fabio,

Thanks for the feedback. You are correct that this is indeed a bug. The good news is that we have already identified and fixed the issue (in build 18895). We will be uploading this build to our servers this afternoon. You will eventually be able to download it using the same “download Vista 3” link you received in your initial access email.

Thank you Jack, i will download and leave feedback after tried.
Thank you again

Another question related to the modifier buttons, the blu modifier appear to be on the “Windows function button” of my laptop, it is quite annoying because obviously after Being pressed it opens me the windows menu and as secondary issue it cant let me take correct screenshot of the screen.
Short question: “wouldnt it be better to have it on “alt gr” button instead?
Thank you again

Hello Fabio,

Right ALT or CNRL + ALT is also BLUE. You can press these keys without the Window menu popping up.

Needless to say, the windows pop up does not happen in Console mode, but you have two other ways of getting to BLUE as keyboard shortcuts.


I’m sorry Jack, maybe sometime is difficult for me to explain the problem.
WHat i meant is that if i press the windows button (for example to take a screenshot, it act as the blue modifier changing the consolle appearance with the jump state (and if i was going to take a screenshot of the consolle that is not good) and while i release the windows button the windows pop up appear over the consolle, i made a video but cant upload here

Ahh OK, I understand what you are trying to say.

I would suggest that it is unlikely that we are going to change Vista’s behavior purely based on some users inability to record Windows screenshots. Most computer keyboard are slightly different in this respect. Some have dedicated print screen buttons, whilst others use FN + printscreen etc etc.

Whilst not endorsed by Chroma-Q, may I personally recommend installing and using Ducklink ?
Quacky link

This is a small bit of software that sits in your system tray. Its quite a powerful snipping tool, which I use all of the time. In addition you can program your own shortcut combinations to snap or record whatever you want :grinning:

thank you for the input, i’ll give it a try