Midi Timecode With Reaper delayed

Im using Reaper too create a time-coded show with vista 3 but theres a delay on when i click pause on Reaper and on the clock i have on vista. Im on mac using Audio midi setup to make a virtual midi thing. I’ve tried this on 2 macs and i have the same problem so i dont know what the issue is. Frames are matched, the routing on Reaper is good. I dont know why theres a delay. The delay is around 1 second after clicking pause on reaper.

When running timecode with Vista, I’m pretty sure that Vista will automatically try to help reduce dropouts by assuming that timecode is running even if Vista misses a few frames of TC. Only after a full second or two of no timecode will it realize that there really isn’t any timecode coming in and stop.

Note that this has nothing to do with the timecode signal being delayed or not. Try starting timecode and watching the clock in vista. The clock in vista should “pick up” the timecode nearly immediately after you start it. So there isnt actually a delay between Reaper and Vista.

Hope that helps!

What Drew said!
That setting is called “freewheel”

To edit, go to the menu File > Timecode

When I use MIDI as the timecode source I am not able to change it to anything below 0, so is there a way to have no delay after pausing on reaper? I am using the latest version of vista and a new issue i see is that the timecode does not start at 0 seconds at the start, it starts from 4 seconds and 18 miliseconds.

Setting Freewheel to 0 does mean that there is no delay after pausing on reaper.

As for timecode starting later, confirm that timecode offset and playback lag compensation are both set to 0 (as shown in my screenshot above). If the issue still persists then it must be something with how you have reaper set up or your timecode file in reaper.

@jack.moorhouse Is there a way too put Freewheel to 0 while using MIDI timecode because Freewheel makes it annoying to use reaper to time cues in my situation

No there is no way to set the freewheel to 0s. That would likely cause playback issues in a lot of situations.

I have used MTC from Reaper pretty regularly and have never had any delay. I suspect there is something else going on in the connection between the two machines. Make sure there aren’t any redundant connections and that you are sending MTC on a single midi interface. If you are sending MTC twice and Vista is connected to two different interfaces both with MTC there could be “echos”.

Is there anything you recommend i do because im trying to use reaper as like a timestamp thing so when i click pause i know where to put a cue and then do that again and again but i cant do that if theres a 1 second delay bc of freewheel

Why don’t you set “reaper” to show you the timecode value within reaper itself ?
Hit pause in Reaper.
Note the timecode time
Manually type this into a cue in Vista.

Hi Dogo,
Are you aware of learn timings to get timecode stamp in that way? May save you a lot of time
Also the timecode isn’t “delayed” as such. It just keeps going in Vista for 3 seconds (or however long it is set) after you press pause. (as explained above it keeps a smooth show if there are any hiccups in the timecode) So you could just pause it and take away 3 seconds from the time shown (or set it to 1 second for easier maths!)

I was thinking about doing that but now since i have confirmed that there is no other way i guess i’ll do this, Thank you all for your help!

Usually I will first put markers in Reaper to find the exact locations that I want to place my cues. Then I open a TC window in Reaper to take those TC values and put then directly into my Vista cues. I have also had some fun with setting up the Reaper timing scale to Measures and Beats to allow the cursor to lock to the beats. This makes it very easy since that never is the same as the TC value.

I also use Learn Timing to time stamp cues as I play them in Vista. This is a bit “rougher” in my experience. I’ll use it to get he cues in the locations that I want but then usually will come back with the actual TC number from Reaper to make them exact (or cheat them early to account for fixture delay).