FX Rate not working with R3.1

I recently updated Vista to the new R3.1 version. When I did it, almost everything worked as it should, but my FX rate fader randomly stopped working and automatically set the speed of my FX to a pretty slow pace. I was able to load out of the show since I hadn’t saved it yet, and it worked again. I tried recreating the issue and I couldn’t get it to repeat. Is this a one time issue or should I be worried about it happening again? Also, since the update one of my effects isn’t working how it did before. Right now it will start the effect and then it will snap and start over. Could it be that I just need to update the effect since it was created in Vista 2 and the values might have different meanings now?

One step you could try would be creating a new Vista 3 show, then merging your Vista 2 show into it. Sometimes, using merge will yield better results than just opening the old Vista 2 showfile.

Generally though, I wouldn’t expect everything to transfer perfectly between Vista 2 and Vista 3. A lot of changes were made in the software between those versions, and so some aspects of a showfile may not transfer properly. As long as most of your showfile is fine, rebuilding 1 or 2 effects isn’t a major hassle. Also keep in mind that the behavior of some effects may have been changed in Vista 3 anyway, so your effects may have imported properly but the behavior was simply different in the new version.

As for the FX rate fader issue, that was likely a one time thing where the fader had to be refreshed or something with the new version of Vista. I wouldn’t be concerned about it happening again.


Effects were reworked in Vista 3 altogether so yes you would have needed to refresh the rate and resave.

I would also recommend checking out the new Vista 3 User Guide and looking at the section on the new FX masters. This could help streamline your workflow for multiple effects.